The search request was unable to connect to the Search Service

I had an issue on a SharePoint 2007 server recently that wasn’t immediately obvious to me (it may well have been obvious to you however).

Whenever searching using the Microsoft Search product the following error would be returned immediately:

The search request was unable to connect to the Search Service

After a little bit of head scratching, checking options in Shared Services and checking of Application Poole accounts I was looking at the list of services in Windows Service Manager and noticed that the Office SharePoint Server Search service had stopped (unbeknown to me).  Restating this service fixed the issue immediately.

Happy days!

Advertisements
This entry was posted in MOSS, Search, services, SharePoint, SharePoint 2010, Windows and tagged , , , , . Bookmark the permalink.

One Response to The search request was unable to connect to the Search Service

  1. Zahra says:

    What to do when it is in constant state of reading just “stopping” It will not even offer option of restart.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s