Author Archives: MJ

Failed to initialize session with document engine: Unable to resolve Contentdistributor

I recently experienced a problem with SharePoint 2010 and FAST content sources which turned out to be a quick fix – once I had spent over an hour tying to figure out what was causing the issue. FAST and SharePoint … Continue reading

Posted in FAST Search, SharePoint, SharePoint 2010 | Tagged , , | 4 Comments

Unexpected error when creating Fast Search Center

I was having a frustrating problem recently with a brand new site collection in SharePoint 2010.  Each time I attempted to create a new FAST Search Centre site an unexpected error would quickly occur with a different correlation ID each … Continue reading

Posted in SharePoint, SharePoint 2010 | Tagged , , , , | Leave a comment

Accessing the Global Assembly Cache using Windows Explorer

Accessing the Global Assembly Cache using Windows Explorer This is something I have to look up every time I need to do it as I always managed to forget, so I thought it may be something that is useful to … Continue reading

Posted in .Net, GAC, Visual Studio.Net, Windows | Tagged , , , | 1 Comment

SharePoint object model updates not triggering workflow

A situation I have observed a number of times while working with the SharePoint object model is that workflows don’t appear to be triggered on update calls. In the past I have worked around this issue by simply adding some … Continue reading

Posted in .Net, C#, MOSS, SharePoint, SharePoint 2010, Workflow, Workflow | Tagged , , , , , | 1 Comment

Search Core Results Web Part – How to view raw XML

Sometimes when working with the Search Core Results web part within SharePoint it may be useful to see all of the XML that is being returned to the XSL stylesheet. It is possible to see the raw XML by replacing … Continue reading

Posted in MOSS, SharePoint, SharePoint 2010, Web Part | Tagged , , , | Leave a comment

Access denied – Microsoft loopback security check

I recently experienced an issue with a server which had me scratching my head for a couple of hours.  Fortunately my colleague had previously experienced this issue and promptly directed me to a Microsoft KB which allowed me to resolve … Continue reading

Posted in IIS, IIS 7, Registry, Search, Security, SharePoint, SharePoint 2010, Windows | Tagged , , , , , , , , | 1 Comment

The crawl rules may have to be modified to include this address. (0x80040d07)

I was recently reminded of a problem I had previously experienced but subsequently forgotten with regard to MOSS content crawling. In this particular instance I was using a custom protocol handler but I believe this issue will apply to the … Continue reading

Posted in MOSS, Protocol Handlers, Security, services, SharePoint | Tagged , , , , | Leave a comment