Tag Archives: MOSS

SharePoint object model updates not triggering workflow

A situation I have observed a number of times while working with the SharePoint object model is that workflows don’t appear to be triggered on update calls. In the past I have worked around this issue by simply adding some … Continue reading

Posted in .Net, C#, MOSS, SharePoint, SharePoint 2010, Workflow, Workflow | Tagged , , , , , | 1 Comment

Search Core Results Web Part – How to view raw XML

Sometimes when working with the Search Core Results web part within SharePoint it may be useful to see all of the XML that is being returned to the XSL stylesheet. It is possible to see the raw XML by replacing … Continue reading

Posted in MOSS, SharePoint, SharePoint 2010, Web Part | Tagged , , , | Leave a comment

Access denied – Microsoft loopback security check

I recently experienced an issue with a server which had me scratching my head for a couple of hours.  Fortunately my colleague had previously experienced this issue and promptly directed me to a Microsoft KB which allowed me to resolve … Continue reading

Posted in IIS, IIS 7, Registry, Search, Security, SharePoint, SharePoint 2010, Windows | Tagged , , , , , , , , | 1 Comment

The crawl rules may have to be modified to include this address. (0x80040d07)

I was recently reminded of a problem I had previously experienced but subsequently forgotten with regard to MOSS content crawling. In this particular instance I was using a custom protocol handler but I believe this issue will apply to the … Continue reading

Posted in MOSS, Protocol Handlers, Security, services, SharePoint | Tagged , , , , | Leave a comment

The search request was unable to connect to the Search Service

I had an issue on a SharePoint 2007 server recently that wasn’t immediately obvious to me (it may well have been obvious to you however). Whenever searching using the Microsoft Search product the following error would be returned immediately: The … Continue reading

Posted in MOSS, Search, services, SharePoint, SharePoint 2010, Windows | Tagged , , , , | 1 Comment

Creating new CustomActionGroups for CustomAction items

I recently wanted to add some links to the Site Settings page of a SharePoint 2010 server when installing a custom feature.  By default there were seven groups available to choose from where I could place my feature related links, … Continue reading

Posted in MOSS, SharePoint, SharePoint 2010, XML | Tagged , , , | Leave a comment

SharePoint Internal Field Names – SharePoint 2010

I noticed today that Frode has recently added a new blog post with an updated list of internal column names for SharePoint 2010. I linked to Frode’s original blog post for MOSS 2007 a couple of years ago so it … Continue reading

Posted in SharePoint, SharePoint 2010 | Tagged , , , , | 20 Comments

Update Content Type including children

Recently I have been doing some work with Content Types via the SharePoint object model and as well as the read only issue which I have also posted about I ran into a security issue.  Whenever attempting to update a content type … Continue reading

Posted in SharePoint | Tagged , , | Leave a comment

Updating Content Types

I was having a problem recently where I was unable to issue an update command on a content type without running into the following error: “The security validation for this page is invalid. Click Back in your Web browser, refresh … Continue reading

Posted in SharePoint | Tagged , , | 1 Comment